Archiwum

Archive for Grudzień 2014

PostSharp płata figle czyli w poszukiwaniu biblioteki, której nie ma

Grudzień 25, 2014 Dodaj komentarz

Podczas kompilacji programu z nienacka otrzymuje komunikat:

image

Kluczowa informacja jaką powinniśmy dostrzec to:

Cannot find assembly ‘system.web.http, version 5.0.0.0

i

found file (…) with identity ‘system.web.http’ wersja 5.2.2

’Komunikat podobnej treści już miałem w swoim projekcie jakiś czas temu i był on spowodowany tym, że jedna z bibliotek podłączona do projektu wymagała wersji 5.0.0.0  System.Web.Http a ja miałem wyższą. Wtedy problem rozwiązałem wpisując w app.config (lub web.config) w sekcji

image

taki oto dodatek:

image

i problem z głowy.

Dzisiaj jednak PostSharp odezwał się do mnie i prosi o wpis ekskluzywny dla siebie.

Jeżeli mamy podobny problem musimy odładować felerny projekt, wejść w edycję pliku projektu .csproj i wpisać tam

image

Ładujemy projekt ponownie i kompilujemy.

image

Działa!

Założenie konta Apple Developer to nie prosta sprawa–hackujemy system

Grudzień 19, 2014 Dodaj komentarz

Czasem tak się zdarza w życiu programisty, że trzeba wyjść z strefy komfortu I pójść do konkurencji zwanej Apple i założyć tam konto… tak też było kilka dni temu – dla jednego z Naszych klientów postanowiliśmy założyć konto w Apple Store.

Niestety przechodząc poszczególne kroki kreatora zawsze finalnie trafialiśmy na komunikat

apple

Back, Go, Back, Go, Back, Go… nic nie pomagało.

 

Na jednym z forów, niestety już nie pamiętam gdzie ponieważ przeglądałem ich dziesiątki znalazłem podpowiedź, że wszystkiemu jest winne pole z Krajem.

Faktycznie głębiej patrząc na to pole widzimy, że pole z krajem… zniknęło, nie można go wpisać. Dzieje się tak według Apple na niektórych kontach – losowo?

 

image

 

Pole z niewiadomych powodów jest ukryte co widać w kodzie strony

image

 

Wystarczy w dowolnych narzędziach dla programistów np: w Chromie czy Internet Explorer podmienić to pole na wygenerowanej stronie – w kodzie strony i tak formularz wysłać – działa!!!

Magia! i to wszystko kosztuje tyle kasy…

Kategorie:Life Hacking

Jak zainstalować starszą wersję paczki z NuGET

Grudzień 6, 2014 Dodaj komentarz

Dzisiaj po raz pierwszy dotknęła mnie sytuacja kiedy potrzebuję zainstalować starszą wersję paczki niż ta najnowsza jaka jest dostępna w systemie paczek NUGET – paczka, o której mowa o PostSharp, a wersja to 3.1.52

Szukając rzeczowej paczki w Visual Studio otrzymuję niestety wersję 4.x

image

 

To co zrobić by zainstalować wersję starszą?

image

 

W rzeczowym oknie wystarczy wpisać  Install-Package PostSharp -Version 3.1.52

I po chwili paczka zostanie zainstalowana!

image

 

Ufff, lubię NuGET – a od teraz jeszcze bardziej – wszystko w jednym miejscu!

Kategorie:.NET, Visual Studio Tagi: